CVE-2026-48144
CVE-2026-48144
9.1
CriticalPublished:
Last updated:
Source:security@apache.org
Analyzed
Weakness (CWE)
CVSS Vector
v4.0- Attack Vector
- Network
- Attack Complexity
- High
- Attack Requirements
- None
- Privileges Required
- None
- User Interaction
- None
- Confidentiality (Vulnerable)
- High
- Integrity (Vulnerable)
- High
- Availability (Vulnerable)
- None
- Confidentiality (Subsequent)
- None
- Integrity (Subsequent)
- None
- Availability (Subsequent)
- None
Description
Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift c_glib bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.
References
security@apache.org
https://lists.apache.org/thread/2xoltfxgzf5jyhcwq6y07spts5cn6ppjsecurity@apache.org
https://lists.apache.org/thread/7v3jhgwfbmhx42424phydlnzb109g8b9af854a3a-2127-422b-91ae-364da2661108
http://www.openwall.com/lists/oss-security/2026/07/24/35