CVE-2026-49877
CVE-2026-49877
8.1
HighPublished:
Last updated:
Source:security@apache.org
Analyzed
Weakness (CWE)
CVSS Vector
v3.1- Attack Vector
- Network
- Attack Complexity
- Low
- Privileges Required
- Low
- User Interaction
- None
- Scope
- Unchanged
- Confidentiality
- High
- Integrity
- High
- Availability
- None
Description
Improper Authorization vulnerability in Apache ActiveMQ. An authenticated low-privilege Web Console user by default can access /admin/* paths in the Web Console. The default Jetty settings incorrectly did not limit those paths to only admins. This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7. Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.
References
security@apache.org
https://lists.apache.org/thread/w82vtc3q02j5ot94tnyy1197y3wb98hlaf854a3a-2127-422b-91ae-364da2661108
http://www.openwall.com/lists/oss-security/2026/06/29/9